Windows 7 Service Pack 1 is here!

Windows 7 Sevice Pack 1 was released to manufacturing in February of 2011. Below is my experience with installing the service pack complete with screenies. My main purporse for installing the service pack so quickly is to be able to test the RemoteFX components of Windows 2008 R2 SP1 RDS. I am currently piloting 2008 R2 RDS to determine if it suites my needs for some application deployment. Another post on that at a later date, but for now onto installing SP1 on my client workstation. Hopefully I don’t break anything as I have alot of admin consoles and so on installed on this workstation. Here goes….

The .iso file that I have downloaded is 1.9GB in size on disk. They are getting large these days but it does in fact contain all languages and all versions of the service pack. Digging into the iso via Windows Explorer confirms that all three versions, (ia64, x86 and x64) are included in the image file.

Win7 iso contents

Executing the autorun.exe file contained on the DVD image file, presents me with the following notification window and allows me to either cancel or proceed with the installation of the service pack.

Clicking next begins starts the installation process and also prepares the computer for the service pack installation. I’m assuming that what is happening here in the background is the installer is runing some prerequisite checking to determine the proper version and language needed to proceed.

After the prep work has been completed, I am presented with a new window telling me to save my work, close all open programs and click Install. Also, note that by default the installer is configured to restart the computer when the installation is completed.

The first thing that takes place as part of the installation is the creation of a system restore point. Then immediately following the installer attempts to download a .cab file for my version of Windows 7. (x64). I would love to know what is required to download at this point when I have already downloaded a 1.9GB iso file??? I plan to dig!

Immediately following successful download of required files, the installer moves right into the installation of the service pack.

After the installation wizard was completed which took approximately 30 minutes on my system an automatic shutdown of my system was initiated.
Before completely shutting down, I was brought to a Configuring Service Pack screen which forgive me but was only able to grab a screenie with my Windows 7 Phone.
This entire process of configuring took about 5 minutes to complete followed by a shutdown. I will replace this image with a nicer one when I run the installation again on a virtual machine.

As my system booted, I was presented with the familiar preparing to configure system notification followed by a second configuring service pack notice. This also took about 5 minutes to complete which I was then presented with the Cntrl + Alt + Del login prompt.

After login to my system I was then presented with a notice that Windows 7 Service Pack 1 installation was completed.

Current installation time on my system which has guts consisting of 4GB of memory and a Core 2 Duo @ 2.93 was just under 1 hour. At first glance everything has seem to have went smoothly. If I find any broken applications that I have installed or anything of interest I will be sure to post.

Onto installation of Service Pack 1 for Windows Server 2008 R2….

Advertisements
This entry was posted in Windows 7. Bookmark the permalink.

One Response to Windows 7 Service Pack 1 is here!

  1. Chris Meehan says:

    Realized this morning that the .iso file I was able to download contains not only all versions for x86, x64 and ia64 but is also for both client and server installations.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s